How to Flash a Gigabyte Motherboard with Q-Flash Plus

Introduction

I recently released a new YouTube video, called “How to Flash the Gigabyte B550 AORUS MASTER BIOS with Q-Flash Plus“. This video walks though and demonstrates all of the steps required to use the Q-Flash Plus feature on this motherboard.

How to Flash a Gigabyte Motherboard with Q-Flash Plus
Rear I/O Panel on Gigabyte B550 AORUS MASTER

Q-Flash Plus is a special feature that lets you flash the BIOS without having a CPU, RAM, or video card installed. The most common reason you would want/need to do this is if you had a new CPU that was not supported by the existing BIOS version on the motherboard.

This situation is happening to a number of people with new Ryzen 5000 Series processors that require a newer BIOS version than was available when the motherboard was manufactured. This feature can also be useful if a more traditional BIOS update (using the Q-Flash BIOS utility or the @BIOS Windows utility) failed.

How to Flash a Gigabyte Motherboard with Q-Flash Plus

Here are the high-level steps that I show in the video.

How to Flash a Gigabyte Motherboard with Q-Flash Plus
Key Steps to Using Q-Flash Plus

Here is the video.

Final Words

I think this is a useful video right now because the documentation on the product web site and in the motherboard manual is a pretty sparse. Gigabyte also has their own YouTube video showing how to do this, but it uses a different motherboard.

I also have blog post about doing this same type of operation for several MSI motherboards.

If you have any thoughts or questions about this post, please ask me here in the comments or on Twitter. You can also follow me on Twitter, where I am @GlennAlanBerryThank you for reading!

Categories AMD, PC HardwareTags

38 thoughts on “How to Flash a Gigabyte Motherboard with Q-Flash Plus

  1. Thank you for your post! Had no luck using a new flash drive. Your detailed list of particulars directed me to use an old 8 gig flash drive that I had which worked perfectly. Many Thanks, Jim

    1. Great! I’m glad you got it working. Thanks!

      1. Claudio Sousa Santos September 26, 2021 — 2:21 am

        i think you made this tutorial not very god, the suposed file schould be named at GIGABYTE. bin and not gigabyte.bin, you got to write it in big lethers and not small like you wrote on your tutorial, please rewrite it so the people don´t do the same mistake as i did, the file schould be named GIGABYTE.bin

      2. You need to check your facts before you start making incorrect statements and accusations. Renaming the file to gigabyte.bin (all lower case) is what Gigabyte specifies on the web site. Here is the exact text:

        “With GIGABYTE Q-Flash Plus, you don’t need to install the CPU, memory and graphics card nor enter the BIOS menu to flash the BIOS. Just download and save a new BIOS file (rename to gigabyte.bin) on the USB flash drive, then press the dedicated Q-Flash Plus button and you’re good to go!”

        It is on this page: https://www.gigabyte.com/Motherboard/B550-AORUS-MASTER-rev-10#kf

        More importantly, renaming it to gigabyte.bin actually works. I have done it multiple times for all of my Gigabyte motherboards, and it works every single time. Thousands of people have followed the directions in my videos and it has worked just fine for them.

        If you are having problems, it is not because of this.

      3. Claudio Sousa Santos September 29, 2021 — 12:12 am

        as you cann see at the Auros homepage here https://global.aorus.com/blog/How-to-Update-Your-BIOS-Part-2.php they say the bios should be named as GIGABYTE.bin. at the end of the month i´m gonna buy a Gigabyte B550 AORUS PRO AC and i will see witch einther gigabite.bin or GIGABYTE.bin schould be writen. best regards Claudio Santos

      4. On the GIGABYTE vs gigabyte issue, I quite doubt Qflash Plus actually uses VFAT anyway, it probably just looks at the 8.3 names. So there’s probably no difference whether you call it GIGABYTE.BIN. gigabyte.bin, GiGaByTe.BiN, Qflash Plus sees the exact same thing, which if you want to get technical is GIGABYTE.BIN. That’s probably in part why different parts of their website say different things

      5. You are probably correct. Q-Flash Plus is very literal and simple-minded. It looks for a file with a particular name in the root of a flash drive that was formatted with FAT32. The flash drive has to be in the correct USB port. If it finds what it is looking for it tries to read the file and then proceed with flashing the BIOS. Otherwise, it just stops.

    2. Great post! It’s ridiculous that Gigabyte’s own manuals explain just about nothing.

      When I initiated Q Flash, it did its thing for a while but eventually the system powered on and got stuck on mb code 91 – “Issue event to connect drivers.” I also get no display. Any idea what’s going on there? Think it’s related or do I have another problem on my hands? 🤔

      1. There is a difference between Q-Flash and Q-Flash Plus. This video is about Q-Flash Plus.

        What CPU are you using? Do you have a discrete GPU, and is your monitor plugged into that (instead of the video port on the motherboard)?

      2. Thanks for the reply. I didn’t realize there’s a difference, but mine does in fact use Q-Flash Plus.
        I’m not at all certain how, but it all ended up working. I was plugged into the mb at the time of my comment, but decided to try it again with the gpu installed. After a few false starts and a thousand updates, I’m rolling along nicely. 🙂
        Thanks again for your descriptive video. You helped this clueless newbie get his first build running!

      3. I know this is an old post, but since no one responded to it with more technical information, there are some very common mistakes that can happen. A common mistake is to forget to plug in the supplemental 8 pin at the top of the motherboard when trying to boot. Flashback will work without it, but making sure that you plug in the 24 plus the 8, or even the 8+4 or 8+8 power will make sure the CPU gets enough power.

        While the majority of Intel processors have graphics built into them(F at the end of the name means no graphics), the majority of AMD desktop chips don’t have graphics. AMD Ryzen desktop chips with a G at the end(5300G or 5600G for example) or any of the new Ryzen 7000 desktop chips(Zen4) will have graphics built in(not needing a video card), but the rest of the Ryzen chips do NOT have graphics built into them, even if your motherboard has the connection. This means that you MUST use a video card if you want to get anything to show up on your monitor.

        Make sure to use a USB 2.0 flash drive, USB 3.0 may have problems with BIOS flashback, even if you have it formatted FAT32 and even if the flashback process seems to work.

    3. This is a somewhat common problem with BIOS flashback. Many motherboard makers don’t tell you that USB 3.0 flash drives often have problems with flashback, but USB 2 flash drives will work. FAT32, yep, USB 3.0 flash drive, flashback fails. USB 2.0 flash drive with the same formatting works fine. Note that I use a Windows 10 install flash drive that I use to install or upgrade other Windows 10 machines that have problems upgrading via Windows Update, one is a USB 2.0 drive, the other a USB 3.0 drive, same Media Creation Tool used to make both within an hour of each other, so yep, the problem was that USB 3.0 doesn’t always work.

  2. how i know it is over?

    1. When the BIOS flash LED stops flashing, which should take 6-7 minutes.

  3. Can you please help me, I have z490 vision G motherboard and it doen’t have q flash button, how can I flash the bios?

    1. If your system will POST, then you can use the regular Q-Flash utility in the BIOS to flash the BIOS.

  4. I set up my i9 with this tutorial:

    https://www.youtube.com/watch?v=l-MAeQXrUlg

    When it has done, I restart, and then no display on the monitor. Please help.

    The motherboard I have is this:

    GIGABYTE Z490 Vision G (Intel LGA1200/Z490/ATX/2xM.2/Realtek ALC1220-VB/Intel LAN/SATA 6Gb/s/USB 3.2 Gen 2/SLI Support/HDMI/Motherboard)

    When I press the power button, computer turns on, all the fans turn on but nothing shows on the screen and when I press the power button again, then it turns off right away

    1. I have no idea what might be wrong based on the symptoms you describe. It could be many different things. What CPU are you using? Do you have a discrete GPU? What video port are you using (is it on the GPU or from the motherboard)?

      Not all Intel CPUs have integrated graphics.

    2. Ok, another older one. So, basic issue: Not all Intel chips have integrated graphics. If you install a video card, you need to connect the monitor to the video card since in most cases, that will disable the integrated graphics. Make sure you have plugged in, not just the main 24 pin power to the motherboard, but also the supplemental 8 pin, or 8+4, or 8+8 power connectors. Make sure these also are plugged into the power supply properly. PCI Express power connectors should not be plugged directly into the motherboard(I’ve seen people do that).

      BIOS flashback can help in many cases where things have become corrupted. Make sure to use a USB 2.0 flash drive for flashback, not a 3.0 drive. USB 3.0 flash drives can sometimes seem like they are working, but then fail. Next, check your RAM. Shut down, take out all RAM(computer memory) from the system, then power up. Look for the LED indicators on the motherboard to see that the motherboard itself is trying to POST. Then, shut down, and try a single memory module. Try in slot 2(counting from the CPU, 1, 2, 3, 4), then power on, and see if the BIOS lights indicate it is actually trying to cycle up. You can then try a different memory module in slot 4, see if it comes up or not.

      You will want to have a WIRED mouse plugged into one of the rear(not front panel) USB connectors, and if the mouse lights up, that implies that the system was able to POST.

  5. Thank you, a most useful post. There is just one piece of information missing. How do you know that your newly purchased motherboard needs an update, without installing your Ryzen 5000 series cpu and hoping for the best? The answer (found elsewhere on the net) is that the first four digits of the motherboard serial number are the year and week of manufacture. Mine, purchased today, was SN2033…. So week 33 in 2020 or 16 Aug to 22 Aug. No chance for me of at least an F10 bios.

    1. Unless you see a logo or sticker on the motherboard box that says that it is “Ryzen 5000 Series Ready” (or something similar), it is pretty safe to assume that you will need a BIOS update for a Ryzen 5000 Series processor. Certain brand new model motherboards (that were just introduced recently) already have this.

      Otherwise, you can just flash to the latest version using Q-Flash Plus, or you can assemble the system without flashing and see if it will POST. If it won’t POST, you can still use Q-Flash Plus on a fully assembled system. Don’t try to turn it on normally, just follow the instructions in the video.

  6. Thanks so much! This is a much better description than the one provided in my mobo manual.
    Just walked through the process and it was easy. However, I have a problem that I am hoping you could help with. After pressing and holding down the flash button for a few seconds the lights and fans in my system turned on as described (took a couple seconds after I released the button). However that was three hours ago and the BIOS is still updating. System is fulling assembled using a Gigabyte X570 Aorus Master Rev 1.0 mobo, Ryzen 5900X CPU and EVGA GTX 3080 FTW3 Ultra. Code A3 is permanently displayed on the mobo but I don’t think that is a problem based on the meaning in the manual. Do you have any idea what the problem might be? I didn’t see anything come up with my internet search and I don’t want to power down and restart in case I screw up the update.

  7. Thank you for the clear instructions. They are much better than what is provided in the manual. I was able to follow them easily but have run into a snag. After holding down the flash button for 5 second and releasing it all system lights (including the bios update light) and fans started after a two or three second delay. That was over three hours ago and they have yet to shut down. The update appears to have gotten stuck. Do you have idea what the problem is or what action I should take? The only thing I found in my internet search was someone who unplugged it. Can’t say I want to do that as it goes against everything I have ever heard about updating a bios. My system is fully assembled using a Gigabyte X570 Aorus Master Rev 1.0, AMD 5900X and EVGA 3080 FTW3 Ultra. I may have already posted this but did not see it listed. I apologize if the comment was posted twice.

  8. ryan.naff@gmail.com November 22, 2021 — 12:49 am

    followed your guide, unfortuantely when I push down my bios button, no light flashes =O

    1. There is probably a problem with your flash drive or how you prepared the BIOS flash file. It has to be renamed; it has to be in the root of the USB flash drive. The drive has to be formatted with FAT32 and plugged into the correct USB port.

      1. I have a gigabyte a320-s2h and there isn’t a q flash button what should i do? (I have a Ryzen 5600x and my mother board only supports 3000 series so i\I am trying to update the BIOS.

      2. Well, you will need to borrow a Ryzen 3000 series processor (or any processor that is compatible with your motherboard) to temporarily install so you can flash the BIOS to a new enough version to support your CPU.

        AMD used to have a program where they would send you an older, low-end CPU that you could use for this. Another possibility is the shop where you bought it might be able to flash the BIOS for you. Finally, you might consider just returning the motherboard and getting one that has the Q-Flash Plus feature

  9. Great tutorial, you saved my PC build from an expensive and lengthy return/repurchase process. Thanks for posting!

  10. I did the bios update with qflash but the board won’t post. retried it twice, everything looks kosher by following the video but boot up the board: nada. Can’t even get into the bios. Brand new ryzen 5000, tried swapping out to a different video card that I know that works: nothing. I’m using a Gigabyte x570 Aorus Elite.

  11. Thanks for the Best information.

  12. hi, thanks very much–I did what you said, and now I have my PC back! ihave AMD ryzen 3950X, x570 aorus wifi 1.1. t was just black screen, no POST, no bios, nothing, no fans, after I ran gigabyte @bios to update my bios. I prayed, and it took all my strength not to cry and end it all (go to Heaven). I am so grateful for your truthful knowledge.

    I inserted the usb drive, pushed the qflash button on main MB, and the leds started flashing, AMD cpu leds came on, fans came on. wow–jumped with delight! after about 2-3 minutes, usb stopped flashing, monitor was still black. then after 2-4 min, a wonderful message appeared on screen, very attractive, a screen I had never seen before. it said “wait, flashing bios…” then the regular bios came up, then windows 10. oh my God! thank you Jesus!

    shame on gigabyte, microsoft, and evil bill gates. windows is the worst glob of software ever written.

  13. Glenn,

    I am grateful to you for making this information available to those of us that experience the frustrations that stem from lacking information put forth by manufacturers on important processes such as the one detailed in your video.

    We recently experienced a fairly insignificant power interruption overnight and somehow the BIOS on my Gigabyte Aorus Pro B550M had been affected. This is critical to our business as the PC is used as a server for all of our company files. This “Server” is protected by a UPS to prevent outages from causing issues like this and it appears to have functioned properly as the PC was still running but would not function when we arrived. I don’t believe I have any settings which would cause the PC to automatically reboot on a power loss.

    As a last ditch effort to potentially restore the functionality of our Server, I knew the board had Q-Flash Plus and your video guided me through the proper procedure on how to flash the BIOS with this feature. I’m happy to announce that it appears to have worked as I’m now able to gain access to my BIOS screen again. I’m going to get the PC put back together (SSD’s still need to be reinstalled) and with any luck (an more confidence now than I’ve had all day) it will boot and everything will be back to normal.

    Many thanks,

    MG ESI

    1. Sorry that happened to you! Hopefully you will get everything working again.

Please tell me what you think

%d bloggers like this:
search previous next tag category expand menu location phone mail time cart zoom edit close